How to install Ecwid on Joomla 1.5

Last updated

This is an old article for old Joomla version 1.5. We do recommend our customers to use the fresh Joomla versions 2.5 or 3.0. If you looking for actual Joomla+Ecwid integration instructions, please refer to the following Joomla article.



​Starting from the version 2.0 of Ecwid Joomla extension, Joomla 1.5 is not supported in our Joomla plugin. Users of Joomla 1.5 can still install and use the old legacy RokEcwid extension, but the new features and improvements will not be added to it. If you have website running on Joomla 1.5, we'd highly recommend upgrading to at least Joomla 2.5 or 3.0 to secure your site, to get the new Joomla features, to access tons of free extensions developed for Joomla 2 and Joomla 3 and to be able to use the new features of Ecwid extension. <

How to install the legacy version on Joomla 1.5

  • Download this extension file: rokecwid_j15.zip 
  • Open the "Extensions → Install/Uninstall" page in your Joomla backend.
  • Upload and install the extension using the "Upload Package File" section. 
  • Go to  "Menus → Main menu" in your Joomla backend. If you have many menus, then select the necessary one instead of the main one. 
  • Click the "New" button.
  • Select "Menu Item Type": "RokEcwid", then select "ECWID Default Layout".
  • Name your page and save the changes.​ In order to 

Manual installation

If you for some reasons cannot use the ready extensions, then you can install Ecwid manually

  • get the integration code from this page: http://help.ecwid.com/customer/portal/articles/1171115-product-browser#Generateyourcode
  • create a new page in your site, open it for editing
  • switch the editor to the HTML mode, i.e. disable the WYSIWYG mode (must-do). Use the 'Toggle editor' button below the texarea. 

    If you use JCE, you should use "show/hide" link to disable the WYSIWYG editor. 

    If you don't see this link, please refer to the article from JCE site on how to enable it: http://www.joomlacontenteditor.net/support/faq/48-editor/226-no-showhide-link

  • insert the integration code and save the changes. Your store is ready, you can view it by opening the saved page.

 

​Recommendations

Joomla 1.5 is no longer supported by Joomla.

We do recommend our Joomla 1.5 customers to migrate to the recent 2.5 or 3.0 Joomla versions.
In order to upgrade your Joomla, please refer to the following upgrade instructions.

Related reading

Joomla integration instruction.
How do I upgrade from Joomla 1.5 to 3.0 version?

Was this article helpful?
0 out of 0 found this helpful
Questions?
Get help
  • Presales Chat

    Need help choosing the right Ecwid plan? Our Sales team has the answer you’re looking for.

  • Forums

    Join the Ecwid community. Discuss support topics and store ideas with other Ecwid users.

  • Contact us

    Still have questions about Ecwid? Let us know! We will be glad to help you with your Ecwid store.

  • Status Monitor

    Get real time status updates on Ecwid services here, 24/7